Для скучающих - можно перечитать инциденты Gitlab и то, как их фиксили (+ - ).
Жаль такое не каждая фирма себе позволить может, эх и эх.
https://gitlab.com/gitlab-com/gl-infra/production/-/issues?label_name[]=incident
Жаль такое не каждая фирма себе позволить может, эх и эх.
https://gitlab.com/gitlab-com/gl-infra/production/-/issues?label_name[]=incident
GitLab
Issues · GitLab.com / GitLab Infrastructure Team / production · GitLab
The GitLab.com Production project tracks changes, incidents and deltas in the production environment.
Куда версию апи реста писать?
Anonymous Poll
78%
/api/v1/foo
9%
/v1/api/foo
3%
другое (коменты)
10%
Результаты
C++ Is to C as Lung Cancer Is to Lung и другие увлекательные главы в книге The UNIX-HATERS Handbook (semi-humorous edited compilation of messages to the UNIX-HATERS mailing list)
The book concerns the frustrations of users of the Unix operating system. Many users had come from systems that they felt were far more sophisticated in features and usability, and they were frustrated by the perceived "worse is better" design philosophy that they felt Unix and much of its software encapsulated.
Ну и книга https://web.mit.edu/~simsong/www/ugh.pdf
Говорят, что заставляет по другому смотреть на дизайн вещей, я хз, ток начал.
The book concerns the frustrations of users of the Unix operating system. Many users had come from systems that they felt were far more sophisticated in features and usability, and they were frustrated by the perceived "worse is better" design philosophy that they felt Unix and much of its software encapsulated.
Ну и книга https://web.mit.edu/~simsong/www/ugh.pdf
Говорят, что заставляет по другому смотреть на дизайн вещей, я хз, ток начал.
oleg_log
Шото я сидел и думал, а почему бы и да? Так вот, попытка собрать полезные однострочники для терминала. Понятия не имею, как сильно надо извращаться, но вот грепаю историю баша с 2017 и ищу полезное, может вы что-то докинете. Коменты или ПР приветствуются.…
А давайте вы
.gitconfig свои пошарите, каждый что-то свое найдет, кроме мейлов и имен, конечно же)Forwarded from Go Дайджест
Где-то плачет от счастья 🥲 маленький Олег. 🤣😂
https://mobile.twitter.com/inancgumus/status/1397168068955021312
https://mobile.twitter.com/inancgumus/status/1397168068955021312
M1RACLES: An Apple M1 Vulnerability https://m1racles.com/
Upd: лан, без заблуждений, кликбейт, цве 404 и с этого нужно всегда начинать
Upd: лан, без заблуждений, кликбейт, цве 404 и с этого нужно всегда начинать
M1Racles
M1RACLES: An Apple M1 Vulnerability
M1RACLES (CVE-2021-30747) is a covert channel vulnerability in the Apple Silicon “M1” chip.
Забавно, но именно сейчас мне понадобилась эта фция (фичи в aconfig, #hq так-то)
https://github.com/golang/go/issues/46336
https://github.com/golang/go/issues/46336
GitHub
bytes, strings: add Cut · Issue #46336 · golang/go
I propose to add to package strings: // Cut cuts s around the first instance of sep, // returning the text before and after sep. // The found result reports whether sep appears in s. // If sep does...
oops https://lobste.rs/s/vvciyk/freenode_is_now_nuking_channels_which
речь про эту штуку https://libera.chat/ (я сперва с ФБскамом криптой Libra попутал, которая уже diem https://en.wikipedia.org/wiki/Diem_(digital_currency))
речь про эту штуку https://libera.chat/ (я сперва с ФБ
oleg_log
А вообще, если посмотреть и подумать, то возникает вопрос: а какой магией они добились миллиардов треугольников в сцене? (дальше идут рассуждения человек не из ААА геймдева). Неужели UE5 даст нам тот некстген о котором говорил Гуфовский? (поорать https:/…
Twitter
Unreal Engine
Unreal Engine 5 is now available in Early Access! Find out more and go hands-on with Nanite, Lumen, and all of the exciting new tools and features: unrealengine.com/blog/unreal-en…
Делаешь
Но есть одно но - оно как-то криво раскуривает разрешения и у меня постоянно летело это
Случайно попробовал и пошло, оно стянуло все образы и теперь обе работают. Аргх.
docker-compose up - говорит сделай docker compose ведь это по современному (Docker Compose is now in the Docker CLI, try docker compose up).Но есть одно но - оно как-то криво раскуривает разрешения и у меня постоянно летело это
failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to create LLB definition: pull access denied, repository does not exist or may require authorization: server message: insufficient_scope: authorization failed
Случайно попробовал и пошло, оно стянуло все образы и теперь обе работают. Аргх.
1 неочень хороший человек сказал, что было бы круто в aconfig докидывать release notes, ну все таки v0.x ломаю что хочу, законом не запрещено.
И ладно бы взять какой-то там Github Action, Goreleaser, да что угодно, но неееееееет, хотелось свой велосипед. Минимальный (и) рабочий.
Венец:
(UPD: в коментах сказали, что достаточно
Удобное:
Релизится ручками по клику на кнопку с указанием тега, обожаю такое.
Полезное:
оказывается на каждом шаге экшенов доступен gh, консольная утилитка-клиент гитхаба, круто (https://cli.github.com/)
Для разговаривающих на языке диффов https://github.com/cristalhq/aconfig/commit/cd64832094c79b67a2dbbb11763d858ce3e53129 (лайк-подписка-колокольчик на пути к v1)
10 потраченных вечером из 10, хочу еще, но пойду спать
И ладно бы взять какой-то там Github Action, Goreleaser, да что угодно, но неееееееет, хотелось свой велосипед. Минимальный (и) рабочий.
Венец:
git log --format="%C(auto) %H %s" `git tag --sort=-committerdate | head -1`...HEAD > changelog.txtПроблема:
actions/checkout@v2 не чекаутит теги, поэтому прямолинейный git fetch --prune --unshallow --tags нужен.(UPD: в коментах сказали, что достаточно
with: fetch-depth: 0 и правда работает)Удобное:
Релизится ручками по клику на кнопку с указанием тега, обожаю такое.
Полезное:
оказывается на каждом шаге экшенов доступен gh, консольная утилитка-клиент гитхаба, круто (https://cli.github.com/)
Для разговаривающих на языке диффов https://github.com/cristalhq/aconfig/commit/cd64832094c79b67a2dbbb11763d858ce3e53129 (лайк-подписка-колокольчик на пути к v1)
10 потраченных вечером из 10, хочу еще, но пойду спать
GitHub CLI
Take GitHub to the command line
oleg_log
https://steveklabnik.com/writing/today-is-my-first-day-at-oxide-computer-company Oxide: Hyperscaler infrastructure for the rest of us We are building a new kind of server. True rack-scale design, bringing cloud hyperscale innovations around density, efficiency…
Oxide Computer Company
The cloud you own. Hardware, with the software baked in, for running infrastructure at scale.
Google Meet обновился https://support.google.com/a/users/answer/10519038?p=meet-cheat-sheet&hl=en
Forwarded from oleg_fov (Oleg Kovalov)
YouTube
Introduction to Amazon Braket, the AWS Quantum Computing Service
Amazon Braket is a fully managed quantum computing service. It helps academics and enterprises accelerate research into quantum computing, and simplifies quantum software development. Amazon Braket provides access to different types of quantum computers including…
The IETF just published QUIC as RFC 9000, supported by RFC 9001, RFC 9002, and RFC 8999. That means QUIC version 1 is officially formalized, and QUIC deployments will now move away from using temporary draft versions to the newly minted version 1. (HTTP/3, the version of HTTP that runs on QUIC, is following closely behind, and should be published soon.)
https://www.fastly.com/blog/quic-is-now-rfc-9000
https://news.ycombinator.com/item?id=27310349
Старый тикет https://github.com/golang/go/issues/32204
Пропозал https://github.com/golang/go/issues/44886
https://www.fastly.com/blog/quic-is-now-rfc-9000
https://news.ycombinator.com/item?id=27310349
Старый тикет https://github.com/golang/go/issues/32204
Пропозал https://github.com/golang/go/issues/44886
Fastly
QUIC is now RFC 9000 | Fastly
QUIC version 1 is officially formalized, and QUIC deployments will now move away from using temporary draft versions to the newly minted version 1.
Зачем еще нужен Rust? переписать консольные тулзовины и запостить на гитхаб. *dropmic*
https://github.com/TaKO8Ki/awesome-alternatives-in-rust
https://github.com/TaKO8Ki/awesome-alternatives-in-rust
GitHub
GitHub - TaKO8Ki/awesome-alternatives-in-rust: A curated list of replacements for existing software written in Rust
A curated list of replacements for existing software written in Rust - TaKO8Ki/awesome-alternatives-in-rust
Знаете что тупо? скачать 20гб игр, а потом понять, что у тебя нет переходника для мыши с USB на USB-C, ведь ты его отдал уходя с работы :(