oleg_log
Хром теперь с поиском вкладок
там чуть ниже оказывается Reading List еще, добавляется по меню на вкладке или по звездочке в закладки
oleg_log
Ну шо, как там Путон без GC ? UPD: вроде Whatsapp тож афк
Да, таки Whatsapp тож афк, в топе Твитора как всегда
Еще у них акк статуса в 2014 умеркак и надежды на Донбассе https://twitter.com/wa_status
Всегда жалко Твитор в этом случае, беднягам приходится каждый спайк отбивать, Спасибо Antirez и Redis.
Еще у них акк статуса в 2014 умер
Всегда жалко Твитор в этом случае, беднягам приходится каждый спайк отбивать, Спасибо Antirez и Redis.
Forwarded from 🇺🇦 Go performance channel (Oleg Kovalov)
Twitter
Marcos Nils
Dear @golang developers, if you're bumping your project to use the new Go1.16 packages, **PLEASE** gatekeep them behind build tags so you don't break projects importing them with older versions. // +build go1.16 // +build !go1.16 Both work to make this happen…
Why Security Defects Go Unnoticed during Code Reviews? A Case-Control Study of the Chromium OS Project
ТЛДР не сделаю ибо забил читать, но вещь крутая, действительно люди заморочились.
http://amiangshu.com/papers/paul-ICSE-2021.pdf
ТЛДР не сделаю ибо забил читать, но вещь крутая, действительно люди заморочились.
http://amiangshu.com/papers/paul-ICSE-2021.pdf
В подкасте @generictalks мы как-то говорили про Kubernetes и одна моя мысля была потеряна (может и озвучил, но запомнил как забыл). Вот она же, но с ХН и от другого человека:
The main advantage of Kubernetes isn't really Kubernetes anymore — it's the ecosystem of stuff around it and the innumerable vendors you can pay to make your problems someone else's problems.
Другими словами: до расцветасоциализма кубов, при смене фирмы (иногда даже команды и отдела!) приходилось погружаться в новую систему оркестрации, со своими башами, путонами и прочими велосипедами одних и тех же проблем.
Как можно догадаться, сейчас выросло одно, большинством признанное, решение, и как минимум в этом есть плюс. А так же выгода для больших фирм, ведь время на онбоардинг стало меньше, ямлы то везде одни и теже.
The main advantage of Kubernetes isn't really Kubernetes anymore — it's the ecosystem of stuff around it and the innumerable vendors you can pay to make your problems someone else's problems.
Другими словами: до расцвета
Как можно догадаться, сейчас выросло одно, большинством признанное, решение, и как минимум в этом есть плюс. А так же выгода для больших фирм, ведь время на онбоардинг стало меньше, ямлы то везде одни и теже.
Недавно вплывал старый коммит ядра, с
Где веселый код
https://github.com/torvalds/linux/blob/d158fc7f36a25e19791d25a55da5623399a2644f/fs/ext4/resize.c#L698
Где комент
https://github.com/torvalds/linux/blob/d158fc7f36a25e19791d25a55da5623399a2644f/fs/ext4/resize.c#L656
Мне интересно, чтобы выбрали вы, как решение такого непонятного кода?
three = 1. Как заметили, это не опечатка, это кривое имя переменной (threes лучше) или комент, но он есть, просто выше.Где веселый код
https://github.com/torvalds/linux/blob/d158fc7f36a25e19791d25a55da5623399a2644f/fs/ext4/resize.c#L698
Где комент
https://github.com/torvalds/linux/blob/d158fc7f36a25e19791d25a55da5623399a2644f/fs/ext4/resize.c#L656
Мне интересно, чтобы выбрали вы, как решение такого непонятного кода?
oleg_log
Недавно вплывал старый коммит ядра, с three = 1. Как заметили, это не опечатка, это кривое имя переменной (threes лучше) или комент, но он есть, просто выше. Где веселый код https://github.com/torvalds/linux/blob/d158fc7f36a25e19791d25a55da5623399a2644f/…
к вопросу выше
Anonymous Poll
14%
комент
32%
изменение имение
47%
изменение имение И комент
7%
другое
Forwarded from oleg_log_plus
Ну вот и PS к предыдущему посту про hedged requests из Tail at scale. Спасибо Богдану (https://t.me/bortlog) за дебаг и интересный диалог.
Если есть вопросы и замечания - дергайте в лс без смущения.
https://github.com/cristalhq/hedgedhttp
#code
Если есть вопросы и замечания - дергайте в лс без смущения.
https://github.com/cristalhq/hedgedhttp
#code
Telegram
Bortlog
Ви можете читати цей блог українською: https://t.me/bortlogua
Forwarded from Sysadmin Tools 🇺🇦
Если вы ждали поддержку ui для #victoriametrics такую же как и #prometheus graph то можно затестить.
Фидбек приветствуется
Фидбек приветствуется
GitHub
GitHub - VictoriaMetrics/vmui: UI monorepo for VictoriaMetrics
UI monorepo for VictoriaMetrics . Contribute to VictoriaMetrics/vmui development by creating an account on GitHub.
Forwarded from normalhead
This media is not supported in your browser
VIEW IN TELEGRAM
Gentoo дольше всех собирается.
TLS 1.0, 1.1 officially deprecated (ietf.org) https://datatracker.ietf.org/doc/rfc8996/
IETF Datatracker
RFC 8996: Deprecating TLS 1.0 and TLS 1.1
This document formally deprecates Transport Layer Security (TLS) versions 1.0 (RFC 2246) and 1.1 (RFC 4346). Accordingly, those documents have been moved to Historic status. These versions lack support for current and recommended cryptographic algorithms…
Forwarded from Hermitage
Intel вкладывает $20 млрд в создание новых фабрик
Коротко:
· две новых фабрики в Аризоне к 2024 году,
· подразделение Intel Foundry Services будет разрабатывать чипы для сторонних компаний,
· готовы аутсорсить производство в TSMC и Samsung,
· будут развивать фабрики в Европе,
· постараются заполучить Qualcomm и Apple в клиенты,
· 7нм "развивается хорошо" 🤔.
https://www.anandtech.com/show/16573/intels-new-strategy-20b-for-two-fabs-meteor-lake-7nm-tiles-new-foundry-services-ibm-collaboration-return-of-idf
Коротко:
· две новых фабрики в Аризоне к 2024 году,
· подразделение Intel Foundry Services будет разрабатывать чипы для сторонних компаний,
· готовы аутсорсить производство в TSMC и Samsung,
· будут развивать фабрики в Европе,
· постараются заполучить Qualcomm и Apple в клиенты,
· 7нм "развивается хорошо" 🤔.
https://www.anandtech.com/show/16573/intels-new-strategy-20b-for-two-fabs-meteor-lake-7nm-tiles-new-foundry-services-ibm-collaboration-return-of-idf
AnandTech
Intel’s New IDM 2.0 Strategy: $20b for Two Fabs, Meteor Lake 7nm Tiles, New Foundry Services, IBM Collaboration, Return of IDF
The new CEO of Intel, Pat Gelsinger, has today outlined his vision for Intel over the coming years. During an online presentation entitled ‘Intel Unleashed: Engineering The Future’, Pat Gelsinger outlined five key topics upon which Intel will work towards…
Обожаю GeoGuessing (самое нёрдовое, что можно придумать).
GeoGuessr is a geographic discovery game. You are dropped into a random Google Street View and tasked with pointing out your location on a map. You can look around, zoom, and follow the car’s path through the local streets.
Статья вроде не супер-супер, ну 66%, в 2 раза лучше какой-то там жены. НО! 66% для открытого решения, если так подумать, то с мощностями NSA и их желанием, проблему можно решить еще лучше (хотя скорее уже решена, лол).
Это и радует, и фольгу на голове напрягает. Куды там AlphaGo ваше.
https://healeycodes.com/geoguessing-with-deep-learning/
GeoGuessr is a geographic discovery game. You are dropped into a random Google Street View and tasked with pointing out your location on a map. You can look around, zoom, and follow the car’s path through the local streets.
Статья вроде не супер-супер, ну 66%, в 2 раза лучше какой-то там жены. НО! 66% для открытого решения, если так подумать, то с мощностями NSA и их желанием, проблему можно решить еще лучше (хотя скорее уже решена, лол).
Это и радует, и фольгу на голове напрягает. Куды там AlphaGo ваше.
https://healeycodes.com/geoguessing-with-deep-learning/
Healeycodes
GeoGuessing with Deep Learning
Applying photo geolocation estimation to the game of GeoGuessr.
А вот и SvelteKit прокачался до релиза.
Wait, what is SvelteKit?
Think of it as Next for Svelte. It's a framework for building apps with Svelte, complete with server-side rendering, routing, code-splitting for JS and CSS, adapters for different serverless platforms and so on.
If you're familiar with Sapper, SvelteKit is Sapper's successor.
https://svelte.dev/blog/sveltekit-beta
(забавно, на странице, при выделении текста, ссылки не выделяются, wow much web 2.0 very web framework)
Wait, what is SvelteKit?
Think of it as Next for Svelte. It's a framework for building apps with Svelte, complete with server-side rendering, routing, code-splitting for JS and CSS, adapters for different serverless platforms and so on.
If you're familiar with Sapper, SvelteKit is Sapper's successor.
https://svelte.dev/blog/sveltekit-beta
(забавно, на странице, при выделении текста, ссылки не выделяются, wow much web 2.0 very web framework)