oleg_log
1.72K subscribers
1.88K photos
131 videos
9 files
2.82K links
Shelter for antisocial programmers "Oleg"

halp: @olegkovalov
web: https://olegk.dev
fov: @oleg_fov
chat: @oleg_log_blabla
podcast: @generictalks
Download Telegram
Я не плачу, просто shuffle seed в глаз попал
Forwarded from Go Дайджест
Где-то плачет от счастья 🥲 маленький Олег. 🤣😂

https://mobile.twitter.com/inancgumus/status/1397168068955021312
M1RACLES: An Apple M1 Vulnerability https://m1racles.com/

Upd: лан, без заблуждений, кликбейт, цве 404 и с этого нужно всегда начинать
oops https://lobste.rs/s/vvciyk/freenode_is_now_nuking_channels_which

речь про эту штуку https://libera.chat/ (я сперва с ФБ скамом криптой Libra попутал, которая уже diem https://en.wikipedia.org/wiki/Diem_(digital_currency))
Делаешь docker-compose up - говорит сделай docker compose ведь это по современному (Docker Compose is now in the Docker CLI, try docker compose up).

Но есть одно но - оно как-то криво раскуривает разрешения и у меня постоянно летело это

failed to solve: rpc error: code = Unknown desc = failed to solve with frontend dockerfile.v0: failed to create LLB definition: pull access denied, repository does not exist or may require authorization: server message: insufficient_scope: authorization failed


Случайно попробовал и пошло, оно стянуло все образы и теперь обе работают. Аргх.
1 неочень хороший человек сказал, что было бы круто в aconfig докидывать release notes, ну все таки v0.x ломаю что хочу, законом не запрещено.

И ладно бы взять какой-то там Github Action, Goreleaser, да что угодно, но неееееееет, хотелось свой велосипед. Минимальный (и) рабочий.

Венец:
git log --format="%C(auto) %H %s" `git tag --sort=-committerdate | head -1`...HEAD > changelog.txt

Проблема:
actions/checkout@v2 не чекаутит теги, поэтому прямолинейный git fetch --prune --unshallow --tags нужен.
(UPD: в коментах сказали, что достаточно with: fetch-depth: 0 и правда работает)

Удобное:
Релизится ручками по клику на кнопку с указанием тега, обожаю такое.

Полезное:
оказывается на каждом шаге экшенов доступен gh, консольная утилитка-клиент гитхаба, круто (https://cli.github.com/)

Для разговаривающих на языке диффов https://github.com/cristalhq/aconfig/commit/cd64832094c79b67a2dbbb11763d858ce3e53129 (лайк-подписка-колокольчик на пути к v1)

10 потраченных вечером из 10, хочу еще, но пойду спать
шож так правдиво
The IETF just published QUIC as RFC 9000, supported by RFC 9001, RFC 9002, and RFC 8999. That means QUIC version 1 is officially formalized, and QUIC deployments will now move away from using temporary draft versions to the newly minted version 1. (HTTP/3, the version of HTTP that runs on QUIC, is following closely behind, and should be published soon.)

https://www.fastly.com/blog/quic-is-now-rfc-9000

https://news.ycombinator.com/item?id=27310349

Старый тикет https://github.com/golang/go/issues/32204

Пропозал https://github.com/golang/go/issues/44886
Знаете что тупо? скачать 20гб игр, а потом понять, что у тебя нет переходника для мыши с USB на USB-C, ведь ты его отдал уходя с работы :(
oleg_log
Photo
помнишь?
Anonymous Poll
81%
да
14%
не
5%
результаты
Оч оригинальная байда от Брэда.

Вместо того, чтобы постоянно комитить вендор или делать форки, этой тулзой можно сделать go mod vendor и комитнуть как тег(!), в итоге все висит отдельно и не мешается в истории

Пример тега https://github.com/bradfitz/go-mod-archiver-test/tree/archive/gomod%2Fa8ea9b345793e2188297f019febc875fb915e94d94f48cce9a4f760413a430b4

Сама тулза https://github.com/tailscale/go-mod-archiver

Вещь скорее редкая, но за этот комит-тег аплодисменты.
Forwarded from Experimental chill
Как и обещал. Ускоряем декомпрессию ZSTD на 5% и делаем его ещё быстрее.
https://github.com/facebook/zstd/pull/2689

5% выиграли в clang в декомпрессии, от -1% до +2% в gcc. Использование специфических инструкций, интересные рассуждения об аллокации блоков кода, их кэширование, сбор статистик бранчей на корпусе, помогаем компилятору лучше справляться с большими кусками заинлайненного кода.

Если вы когда-нибудь задавались вопросом, зачем нужно учить ассемблер, можно показать, вот зачем.

Даже если не примут (в чём я сомневаюсь), то оставим себе, мы увидели хороший прирост.